Guidelines

This site is for tech Q&A. Please keep your posts focused on the subject at hand.

Ask one question at a time. Don't conflate multiple problems into a single question.

Make sure to include all relevant information in your posts. Try to avoid linking to external sites.

Links to documentation are fine, but in addition you should also quote the relevant parts in your posts.

0 votes
4 views
4 views

After upgrading a server to Devuan Beowulf the NIS¹ services fail to start:

root@foo:~ # /etc/init.d/nis start
[FAIL] Starting NIS services: ypserv yppasswdd ypxfrd ypbind[....] binding to YP server...........................................failed (backgrounded).
. ok 

The problem apparently occurs because ypbind is not started:

root@foo:~ # ypwhich
ypwhich: Can't communicate with ypbind

I confirmed via ps ax | grep ypbind that there really is no ypbind process.

However, if I run ypbind in the foreground, it starts just fine:

root@foo:~ # ypbind -d
3662: parsing config file
3662: Trying entry: ypserver foo.example.org
3662: parsed ypserver foo.example.org
3662: add_server() domain: example.org, host: foo.example.org, slot: 0
3662: [Welcome to ypbind-mt, version 1.38]

3662: ping interval is 20 seconds

3662: rebind interval is 900 seconds

3664: ping host 'foo.example.org', domain 'example.org'
3664: Answer for domain 'example.org' from server 'foo.example.org'

and ypwhich gets a proper response:

root@foo:~ # ypwhich
foo.example.org

What is going on here, and how do I fix it?


¹ Yeah, yeah, I know, the 90s called and want their directory service back. Shut up.

ago in General by (15) 4

Your answer

Preview

Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
By submitting this post you agree to our Terms & Conditions.
To avoid this verification in future, please log in or register.

1 Answer

0 votes
 
Best answer

This appears to be a bug in the current Debian package. The ypbind binary in that package doesn't recognize the parameter -no-dbus anymore (even though it's still listed in the man page):

root@argon:~ # ypbind -no-dbus
Usage:
	ypbind [-broadcast | -ypset | -ypsetme] [-f configfile]
	  [-no-ping] [-broken-server] [-local-only] [-i ping-interval]
	  [-r rebind-interval] [-debug] [-verbose] [-n | -foreground]
	ypbind -c [-f configfile]
	ypbind --version

but the package does not replace the existing /etc/default/nis with an updated config (which the package actually contains, see /usr/share/nis/nis.default).

To fix the issue open /etc/default/nis in an editor and replace

...
# Additional options to be given to ypbind when it is started.  
YPBINDARGS=-no-dbus
...

with

...
# Additional options to be given to ypbind when it is started.  
YPBINDARGS=
...

Save the file and restart the service (service nis restart).

ago by (15) 4
edited ago by
...